Uploading algo gives "bad algo name"

Hi! I haven’t played for a long time (a year), and I’m just getting back into it. But for some reason, uploading an algo (any one really, even the ones from the starter kit won’t work (that is, just uploading the language directory)) gives an error saying “bad algo name”, no matter what folder I upload, and what name the folder is. Has anyone else faced this issue or have any idea of how to solve this?

Edit: I’ve also tried to use what I have from last year, but that also didn’t work.

Since you’ve been gone a while, are you uploading the folders or zipped versions of the folders?

Since the website says uploading folders, I just chose a folder to upload. I don’t remember how I zipped the files, and I couldn’t find any information on how to zip them either.

No, that’s good, you’re not supposed to zip the folder.
Can you maybe take a screenshot of what you are uploading?

This is what I had last year, and I’m just uploading the whole folder (this is for Rust):

terminal-feox
├── algo/
│   ├── Cargo.toml
│   └── src/
├── algo.json
├── algo-target/
│   ├── algo*
│   ├── run.ps1
│   └── run.sh*
├── build_local.py*
├── Cargo.lock
├── Cargo.toml
├── example/
│   ├── Cargo.toml
│   └── src/
├── feox/
│   ├── Cargo.toml
│   ├── notes.md
│   └── src/
├── pathtest/
│   ├── Cargo.toml
│   └── src/
├── README.md
├── rustfmt.toml
└── target/
    └── debug/

If I’m trying to upload what’s in the starter kit, I’m just uploading anyone of the *-algo folders:

C1GamesStarterKit
├── community/
├── engine.jar
├── game-configs.json
├── java-algo/
├── License.md
├── python-algo/
├── README.md
├── rust-algo/
└── scripts/

Edit: If you wanna see an actual screenshot, the selected is what I’m uploading: maim-2020-08-13--14-47-36

Well I don’t see anything out of the ordinary, idk guess we’ll have to wait for @C1Ryan

Did you download the newest starter kit? They probably change the basic game code since last year.

Yes I have. That kit is downloaded pretty much just before posting the issue

Edit: Also it’s cloned, so I can be sure that it is the lastest

I did just download the startet kit and uploaded the folder called “rust-algo” and it worked.

Interesting. For some reason this only happens in qutebrowser, which is what I use. But the weird thing is, the upload succeeds in Chrome, even though qutebrowser is just some wrapper around Chromium. Weird web issues.

1 Like

For some reason this only happens in qutebrowser

Did you see the banner recommending that you use google chrome anywhere on the site when using qutebrowser?

No.

Thanks for the feedback.

The ‘Google chrome should work’ banner should display on certain browsers, but has not been updated in some time. I’ll double check it soon and ensure it is correctly displaying on browsers that are more similar to chrome. I am somewhat concerned that the new Edge may have this issue as well since it is chromium based…