Upload the correct Zipped Asset

I uploaded an algo last night that crashed. I fixed the issue with small changes ( < 10 chars) but now for some reason I get this message whenever I tried to upload the fixed algo.

Your algo failed to upload. Please upload the correct Zipped Asset. Click outside of this message to dismiss

I have to wait quite a long time to get this message and sometimes it doesn’t even show up. (the data bank stays empty)

I was not able to find what could cause this and there is not much information in the message.

few things I thought about:

  • the zip folder is quite heavy (3,8 Mo) but as the previous one
  • Sometimes I can upload zip folders I uploaded in the past but sometimes I have the same issue. I thought about an internet connection issue but the tests I ran looked ok.
  • it is indeed a .zip folder and not a .rar or other compresion extensions

Would you have any idea? Has this happened to you before?

Edit: I was in a new place for the week-end and for some reason it did not work there, as soon as I connected somewhere else, I worked.