Unable to run the local engine

I’m unable to get the local engine to run from the provided engine.jar link and get the ‘unable to access jarfile’ error when attempting it with the coman prompt.

What OS are you using?

Also what directory are you running the script. It’s recommended to do it like it is in the README.md where you are in the parent folder and run ./scripts/run_match.sh (for unix).

I’m usind Windows 10 and I’m attempting to run the engine.jar script through the cmd through its program directory. In what do I run the ./scripts/run_match.sh?

Make sure you are using powershell not cmd (powershell should come with your windows, if not its free to download).

Navigate to the directory you have the starter kit, then try the command: scripts\run_match.ps1
Don’t cd to the actual scripts folder stay in the parent directory.

Common issues are:

  • Make sure you have python3 and java10 installed.
  • Turn on powershell execution permissions by the following command: Set-ExecutionPolicy Unrestricted
  • Replay files need to be converted from windows CRLF format to regular unix format when uploading to our using: http://newline.nadav.org/

I’m having the same issue on my Mac OS, any ideas how I can resolve this?

Very strange to see it on mac can you paste the exact command and error your getting?

when I run it I get the following output:

Run Match
P1: algos/starter-algo
P2: algos/my-algo
Starting Match: algos/starter-algo vs. algos/my-algo
Error: Unable to access jarfile engine.jar

Can you paste the exact command you used to run it?

documents/C1GamesStarterKit-master/scripts/run_match.sh algos/starter-algo algos/my-algo

So the run_match.sh script has to be run in the parent directory (because that’s where the engine is), so just cd … up a directory and run:

./scripts/run_match.sh algos/starter-algo algos/my-algo

1 Like

got the same problem, I’ve triple checked that I’m using powershell, installed both python3 32bit/64bit and java10. I’m still getting the same error.
Error: Unable to access jarfile engine.jar

@George did you:


Also, I would recommend against having two versions of python installed (32 or 64 bit) there shouldn’t be a problem with running default modules but in the future, if you try and install other modules there is the possibility of the OS having problems identifying the correct one. It’s hard to say since it depends on how you installed, your PATH, etc but generally, it is a good idea to just have one. Shouldn’t be the problem for what you are describing though.

I have turned on the powershell permissions, so do you recommend 64 bit of 32 bit. I was using 64 bit before but that didn’t work and that’s why I also installed the 32 bit version.

If it says it can’t find jarfile engine.jar it’s because you ran the script in a directory that isn’t the starterkit home directory (where the engine.jar is).

So first cd to that directory, then run:

@George I would recommend using whatever is native to your machine. So if you have a 64 bit machine then I would use that, and vice-versa for 32 bit

thanks, it works now.

1 Like