Java -version

Java -version
0

#1

Hi everyone, i am trying to run match locally on a windows 10 computer. I am struggling to find the needed java version. Could some one provide links?


#2

https://terminal.c1games.com/rules#Troubleshooting

The troubleshooting guide has alot of the common issues we have seen, and the solutions for them. The README documents inside the starterkit should give you more information if you want to check those out.


#3

I also suffered this problem a while back and none of the documented solutions worked for me. I had to wrap it into a .exe program. I wrote a post about how to do it here if you need it. This is definitely a workaround you should only do after you try all other suggestions and official documentation though.


#4

I tried but still have an error (I use powershell, have jdk 11.0.2 and jre 8 both added to path):


PS C:\Users\Yegor\PycharmProjects\C1GamesStarterKit-master\scripts> python run_match.py C:\Users\Yegor
\PycharmProjects\C1GamesStarterKit-master\GetingReal C:\Users\Yegor\PycharmProjects\C1GamesStarterKit-
master\GetingReal
Is windows: True
Algo 1: C:\Users\Yegor\PycharmProjects\C1GamesStarterKit-master\GetingReal\run.ps1
Algo 2: C:\Users\Yegor\PycharmProjects\C1GamesStarterKit-master\GetingReal\run.ps1
Start run a match
Error: A JNI error has occurred, please check your installation and try again
Exception in thread “main” java.lang.UnsupportedClassVersionError: com/c1games/terminal/Terminal has been compiled by a more recent version of the Java Runtime (class file version 54.0), this version of the Java Runtime only recognizes class file versions up to 52.0
at java.lang.ClassLoader.defineClass1(Native Method)
at java.lang.ClassLoader.defineClass(Unknown Source)
at java.security.SecureClassLoader.defineClass(Unknown Source)
at java.net.URLClassLoader.defineClass(Unknown Source)
at java.net.URLClassLoader.access$100(Unknown Source)
at java.net.URLClassLoader$1.run(Unknown Source)
at java.net.URLClassLoader$1.run(Unknown Source)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(Unknown Source)
at java.lang.ClassLoader.loadClass(Unknown Source)
at sun.misc.Launcher$AppClassLoader.loadClass(Unknown Source)
at java.lang.ClassLoader.loadClass(Unknown Source)
at sun.launcher.LauncherHelper.checkAndLoadMain(Unknown Source)
Finished running match
PS C:\Users\Yegor\PycharmProjects\C1GamesStarterKit-master\scripts>


#5

Seems like you may need a more recent version of Java


#6

I had similar issue after updating to latest Java, so downgraded.

This version works for me:

C:\Users\Janis>java -version
java version “10.0.2” 2018-07-17
Java™ SE Runtime Environment 18.3 (build 10.0.2+13)
Java HotSpot™ 64-Bit Server VM 18.3 (build 10.0.2+13, mixed mode)


#7

Yes, can i have a download link please? I tried java 11, java 8 does not work, and java 10 is no more supported by oracle.


#8

Here is the exact one I use: https://filehippo.com/download_jre_64/86384/


#9

[quote=“GronkaLonka, post:4, topic:1005”]
python run_match.py C:\Users\Yegor
\PycharmProjects\C1GamesStarterKit-master\GetingReal C:\Users\Yegor\PycharmProjects\C1GamesStarterKit-
master\GetingReal
[/quote]д


#10

Thanks, that helps


#11

To fix the actual problem you should try to either run the Java code with a newer version of Java JRE or specify the target parameter to the Java compiler to instruct the compiler to create code compatible with earlier Java versions.

For example, in order to generate class files compatible with Java 1.4, use the following command line:

javac -target 1.4 HelloWorld.java

With newer versions of the Java compiler you are likely to get a warning about the bootstrap class path not being set.