Errors attempting to run local match

On windows, when I run the file in the console, it complains about a JNI error then says match has finished. When I run it through IDLE, it complains about an unsupported operation. When I run the .ps1 file, it says it cannot access the engine.jar file. On mac, a similar error appears to occur when I try to run the .sh file. Can anyone point me towards what I am missing?

After copying the run_match.ps1 to the directory with engine.jar in it, it too complains of a JNI error.

I think .sh is only for linux or something

Which directory are you in when you call the game? For all the file paths to work properly you should have your PowerShell directory in the main (engine.jar) folder and then call the script (run_match) from that directory. For example, in the main directory I would call py scripts/ rather than going to the scripts folder and running py

You do not run the files or the other run file directly - It takes two to tango, so we have a script you need to run that will handle running two algos and the game engine. Details on how to do this are in the README in starter kit

The problem currently is that it is complaining that a class “has been compiled by a more recent version of the Java Runtime (class file version 54.0), this version of the Java Runtime only recognizes class file versions up to 52.0”. This error occurs when I attempt to run the python script as per the README’s instructions, or when I have the run_match.sh1 in the same folder as engine.jar and attempt to run that.

PS C:\Users\Doctor5555> cd “C:\Users\Sebastian Wilkinson\Desktop\C1GamesStarterKit-master”
PS C:\Users\Doctor5555\Desktop\C1GamesStarterKit-master> py scripts/
Is windows: True
Algo 1: C:\Users\Doctor5555\Desktop\C1GamesStarterKit-master\algos\starter-algo-ZIPME\run.ps1
Algo 2: C:\Users\Doctor5555\Desktop\C1GamesStarterKit-master\algos\starter-algo-ZIPME\run.ps1
Start run a match
Error: A JNI error has occurred, please check your installation and try again
Exception in thread “main” java.lang.UnsupportedClassVersionError: towerworker/TowerWorker has been compiled by a more recent version of the Java Runtime (class file version 54.0), this version of the Java Runtime only recognizes class file versions up to 52.0
at java.lang.ClassLoader.defineClass1(Native Method)
at java.lang.ClassLoader.defineClass(Unknown Source)
at Source)
at Source)
at$100(Unknown Source)
at$ Source)
at$ Source)
at Method)
at Source)
at java.lang.ClassLoader.loadClass(Unknown Source)
at sun.misc.Launcher$AppClassLoader.loadClass(Unknown Source)
at java.lang.ClassLoader.loadClass(Unknown Source)
at sun.launcher.LauncherHelper.checkAndLoadMain(Unknown Source)
Finished running match
PS C:\Users\Doctor5555\Desktop\C1GamesStarterKit-master>

PowerShell log

Can you link the command you are using to generate this output?
Also, you should make sure you have the most recent version of Java 10 setup on your system.

Second line from top of console log. I’ve tried downloading and installing java se runtime environment 10 already I think, but I’ll try again.

Somehow it does now do more stuff, even though the starter algo crashes in it.

Try running the new python script, details in the readme on how to run it its more robust and less finicky.