Can't Seem to Join the Data Engineer Job Competition

Can't Seem to Join the Data Engineer Job Competition
0

#1

Hi all!

I am new to terminal and wanted to join the Terminal X Data Engineer Job Competition. I just got an email saying that I am accepted and eligible to join, with an RSVP button that leads to the join page. However I can’t seem to join the contest button. The following are screenshots of the error messages.

Can somebody take a look? Greatly appriciated.

Thanks,
Brad


#2

I clicked both the “join” button and the join contest “here” button on the banner. Both buttons seem to lead to the same error message above.


#3

Looking into this now, thanks for letting us know.

Just to confirm, did you complete an application, including an assessment?
It may also be worth trying in incognito mode, with browser extensions disabled. We have had issues in the past where browser extensions interfered with some functionality.


#4

Thanks Ryan! Yes I have completed the application with the assessment. I just tried on different platforms (incognito mode, Microsoft Edge, and my iPhone), and none works. I feel like this is more of a backend issue rather than frontend.


#5

I also noticed that I can’t upload my resume either. Here’s an error message.


#6

Tried to upload it on my profile page.


#7

Hmm, interesting.
I’ll keep looking into it today/tomorrow and probably give you an update tomorrow afternoon. Thanks again for reporting the issue, and for your patience


#8

Thanks so much for this post!

Could you email your resume to games@correlation-one.com

Have you tried a different file to upload the resume?


#9

Hey,

We fixed a rare issue where it was possible for an account to be incorrectly marked as having an uploaded resume, after a resume upload fails. This goes on to causes issues when validating your competition application. This has been fixed, and should no longer affect anyone as of next week.

We are still unsure why your resume fails to upload. Does it happen with all PDF files, or just the one you are using? If you send it to the above email, I can determine why it is failing to upload and then ensure that you are in the competition.


#10

Hi all,

Thanks for looking at the issue. I emailed my file to games@correlation-one.com. I tried to upload another pdf file just now and it did seem to work.

Also, the “join contest” button is still not working for some reason. Is there any way to manually enroll me into the contest?

Thanks,
Brad


#11

I reset the resume upload step on your application. If you go back to the competition page, it should prompt you to upload your resume again.

Looking at the resume you send, it is clear that the upload is failing because the name length exceeds our maximum allowed length. I’ll look into making that failure more clear, and prevent similar issues from happening.


#12

Thanks Ryan! I uploaded the resume again and it sent me back to this page. Could you help me join the contest as well?


#13

You should be invited now, let us know if you have any more issues.

Follow up:
The maximum length of a resume name is 30 characters. There was no reason for this limit, so it has been removed. Code that checks if you have a resume now looks for the resume in the database directly, so it can’t be made ‘out of sync’ in the rare cases that an upload fails or is deleted by an administrator after being uploaded.

These changes will be in next week. Until then, avoid uploading resumes with long file names.


#14

Thanks!