Error at the Algo Upload

The error it shows is:
Your algo failed to upload. Please upload the correct Zipped Asset. Click outside of this message to dismiss
What can I do?

Well first, did you follow the tutorial for uploading?

Yes, I did what the video said.

Server is probably down atm (I’m having same problem).

Maybe that’s the problem.

surely, no match have been played in a while .
Thus I only have the never-ending compiling issue

Thanks for pointing this out. We had hoped this was solved on friday, but apparently it is not. We are putting a band aid on it for now, and will create a proper fix over the next week. Servers may be unstable until then.

Servers should be up within 10 minutes.
Thanks for your patience everyone.

Im getting the following error when trying to upload my algo to the local engine.

Error on simple algo process creation The system cannot find the path specified
at java.base/ Method)
at java.base/ Source)
at towergame.gamecore.player.SimpleAlgoPlayer.(
at towergame.gamecore.player.PlayerManager.setupPlayerFromCommandString(
at towergame.GameMain.main(
at towerworker.TowerWorker.main(
Algo Crashed. Crash: true !processIsAlive: null

Anyone know how to fix it?

Have you installed Python 3 and added it to PATH? Have you installed Java 10+ and done likewise?

I have both installed and I assume that they are added to PATH. I should make it clear that, previous algo uploads have worked fine on the local engine, including the likes of very slightly changed versions of the starter algo. It is only my new fork that gives the error.

Don’t just assume that they are added to PATH, check. That was my problem when I had the same issue.

1 Like

I solved it. I wasn’t uploading the correct zip file.